Posts Tagged ‘electronics’

Linda’s Pet Peeve List

December 26, 2008

cameras2-765753

Hitting my Pet Peeve List just under Car Problems is Electronic Problems.  I believe I”ve mentioned this before, but my lap top took a dive about three months ago.  It would turn on, but I couldn’t get passed the first page of the 1980’s digital font on the “Something’s Wrong” page.  I couldn’t remember all that was stored on there… but I did know our D.C. trip and skiing pictures were only on the laptop.  There was also some of my writing on there too.  We found out we could recover the data for a mere $50 and then throw out the lap top.  This was the laptop that I faithfully watched Netflix movies on while I sewed Bags for Zaza.  I was missing my movies… the portable CD movie player that has a 7″ screen, just wasn’t the same.  Sigh. 

The good news:  seems my laptop just needed a three month nap.  It woke up and all is fine.  My dad copied all data and photos… but I’ve watched Miss Potter twice since my computer came back to me. “There’s something delicious about writing the first words of a story….”

On to current electronic challenges.  Well, 2007 is not current, but the resolution was.  Our video camera battery died.  We would charge it for 2 hours and it would produce 5 minutes of juice for our viewing pleasure.  Our entire video life is captured on 8mm tapes from 1993 to June 2007.  That was when we discovered that the battery needed is an antique… unavailable… not manufactured any more.  Bummer.  So, we asked for a video camera for Christmas because we definitely need to take one to Colombia to capture Zaza’s entrance into the wild and crazy Crosby family.

Fast forward to three nights ago when we had family video night… we decided to check eBay.  Low and behold, there was our prized possession of a battery for $11.49 and free shipping.  Hallelujah!  It’s on its way.

So, last night we are at my parent’s home and trying to take the annual family picture in front of the Christmas tree and the memory card is NOT in the camera.  Oh well.  I deleted some pictures of Larisa’s clay Stonehenge and Trixie sleeping under a laundry basket to make room on the internal storage.  THEN (insert sinister music here) I arrived home to upload the family pictures on the computer and the cord doesn’t work!  WHAAAAAT?  So, it’s onto eBay to find a new camera cord.  Will this ever end?